Super Lab BGP-MPLS-InterAS

Lab_5

1.Core technologies IPV4 AS 1009

  a. Configure OSPF Area 0 AS 1009
b. Use loopback address as router-id OSPF
c. Advertise loopback0 address into OSPF
d. Make sure All loopback0 AS 1009 can ping each other

R1

router ospf 10
network 9.9.13.0 0.0.0.255 area 0
network 9.9.12.0 0.0.0.255 area 0
network 9.9.0.1 0.0.0.0 area 0
router-id 9.9.0.1

R2

router ospf 10
network 9.9.12.0 0.0.0.255 area 0
network 9.9.24.0 0.0.0.255 area 0
network 9.9.0.2 0.0.0.0 area 0
router-id 9.9.0.2

R3

router ospf 10
network 9.9.13.0 0.0.0.255 area 0
network 9.9.35.0 0.0.0.255 area 0
network 9.9.0.3 0.0.0.0 area 0
router-id 9.9.0.3

R4

router ospf 10
network 9.9.24.0 0.0.0.255 area 0
network 9.9.46.0 0.0.0.255 area 0
network 9.9.0.4 0.0.0.0 area 0
router-id 9.9.0.4

R5

router ospf 10
network 9.9.35.0 0.0.0.255 area 0
network 9.9.56.0 0.0.0.255 area 0
network 9.9.0.5 0.0.0.0 area 0
router-id 9.9.0.5

R6

router ospf 10
network 9.9.46.0 0.0.0.255 area 0
network 9.9.56.0 0.0.0.255 area 0
network 9.9.0.6 0.0.0.0 area 0
router-id 9.9.0.6

2.Core technologies IPV4 AS 9

  a. Configure ISIS AS 9,Level-2-only
b. Advertise loopback0 address into ISIS
c. Make sure All loopback0 AS 9 can ping each other

R7

router isis
net 47.0009.0000.0000.0007.00
is-type level-2
int e0/0
ip router isis
int e0/3
ip router isis
int lo0
ip router isis

R8

router isis
net 47.0009.0000.0000.0008.00
is-type level-2
int e0/0
ip router isis
int e0/3
ip router isis
int lo0
ip router isis

R9

router isis
net 47.0009.0000.0000.0009.00
is-type level-2
int e0/0
ip router isis
int e0/1
ip router isis
int lo0
ip router isis

3.MPLS LDP AS 1009

  a. Configure mpls LDP AS 1009
b. Use loopback address as LDP-ID
c. Verify MPLS LDP Running on AS 1009

Konfigurasi ke semua router di AS 1009

mpls label protocol ldp
mpls ldp router-id lo0

mpls ip
interface e0/1
mpls ip

interface e0/0
mpls ip

4.MPLS LDP AS 9

  a. Configure mpls LDP AS 9
b. Use loopback address as LDP-ID
c. Verify MPLS LDP Running on AS 9

R7

mpls label protocol ldp
mpls ldp router-id lo0

mpls ip
interface e0/3
mpls ip

interface e0/0
mpls ip

R8

mpls label protocol ldp
mpls ldp router-id lo0

mpls ip
interface e0/3
mpls ip

interface e0/0
mpls ip

R9

mpls label protocol ldp
mpls ldp router-id lo0

mpls ip
interface e0/1
mpls ip

interface e0/0
mpls ip

5.BGP IPV4 Unicast AS 1009

  a. Configure BGP IPV4 AS 1009 ,make sure by default bgp ipv4 unicast not activate
b. Use loopback address as a router-id BGP
c. R2 is RR AS 1009
d. Advertise loopback 0 into BGP
e. Verify BGP IPv4 Unicast Running on AS 1009

R2

router bgp 1009
bgp router-id 9.9.0.2
no bgp default ipv4-unicast
neigh 9.9.0.1 remote-as 1009
neigh 9.9.0.1 update-source lo0
neigh 9.9.0.3 remote-as 1009
neigh 9.9.0.3 update-source lo0
neigh 9.9.0.4 remote-as 1009
neigh 9.9.0.4 update-source lo0
neigh 9.9.0.5 remote-as 1009
neigh 9.9.0.5 update-source lo0
neigh 9.9.0.6 remote-as 1009
neigh 9.9.0.6 update-source lo0
address-family ipv4
neigh 9.9.0.1 activate
neigh 9.9.0.1 route-reflector-client
neigh 9.9.0.3 activate
neigh 9.9.0.3 route-reflector-client
neigh 9.9.0.4 activate
neigh 9.9.0.4 route-reflector-client
neigh 9.9.0.5 activate
neigh 9.9.0.5 route-reflector-client
neigh 9.9.0.6 activate
neigh 9.9.0.6 route-reflector-client
net 9.9.0.2 mask 255.255.255.255

R1

router bgp 1009
bgp router-id 9.9.0.1
no bgp default ipv4-unicast
neigh 9.9.0.2 remote-as 1009
neigh 9.9.0.2 update-source lo0
address-family ipv4
neigh 9.9.0.2 activate
net 9.9.0.1 mask 255.255.255.255

R3

router bgp 1009
bgp router-id 9.9.0.3
no bgp default ipv4-unicast
neigh 9.9.0.2 remote-as 1009
neigh 9.9.0.2 update-source lo0
address-family ipv4
neigh 9.9.0.2 activate
net 9.9.0.3 mask 255.255.255.255

R4

router bgp 1009
bgp router-id 9.9.0.4
no bgp default ipv4-unicast
neigh 9.9.0.2 remote-as 1009
neigh 9.9.0.2 update-source lo0
address-family ipv4
neigh 9.9.0.2 activate
net 9.9.0.4 mask 255.255.255.255

R5

router bgp 1009
bgp router-id 9.9.0.5
no bgp default ipv4-unicast
neigh 9.9.0.2 remote-as 1009
neigh 9.9.0.2 update-source lo0
address-family ipv4
neigh 9.9.0.2 activate
net 9.9.0.5 mask 255.255.255.255

R6

router bgp 1009
bgp router-id 9.9.0.6
no bgp default ipv4-unicast
neigh 9.9.0.2 remote-as 1009
neigh 9.9.0.2 update-source lo0
address-family ipv4
neigh 9.9.0.2 activate
net 9.9.0.6 mask 255.255.255.255

6.BGP IPV4 Unicast AS 9

  a. Configure BGP IPV4 AS 9 ,make sure by default bgp ipv4 unicast not activate
b. Use loopback address as a router-id BGP
c. R8 is RR AS 9
d. Advertise loopback 0 into BGP
e. Verify BGP IPv4 Unicast Running on AS 9

R8

router bgp 9
bgp router-id 9.9.0.8
no bgp default ipv4-unicast
neigh 9.9.0.7 remote-as 9
neigh 9.9.0.7 update-source lo0
neigh 9.9.0.9 remote-as 9
neigh 9.9.0.9 update-source lo0
address-family ipv4
neigh 9.9.0.7 activate
neigh 9.9.0.7 route-reflector-client
neigh 9.9.0.9 activate
neigh 9.9.0.9 route-reflector-client
net 9.9.0.8 mask 255.255.255.255

R7

router bgp 9
bgp router-id 9.9.0.7
no bgp default ipv4-unicast
neigh 9.9.0.8 remote-as 9
neigh 9.9.0.8 update-source lo0
address-family ipv4
neigh 9.9.0.8 activate
net 9.9.0.7 mask 255.255.255.255

R9

router bgp 9
bgp router-id 9.9.0.9
no bgp default ipv4-unicast
neigh 9.9.0.8 remote-as 9
neigh 9.9.0.8 update-source lo0
address-family ipv4
neigh 9.9.0.8 activate
net 9.9.0.9 mask 255.255.255.255

7.EBGP ipv4 Unicast AS 1009 & AS 9

  a. Configure EBGP ipv4 between AS 1009 & AS 9
b. Use physical interface to activate EBGP neighbor
c. Verify AS 1009 loopback0 reachable by AS 9 loopback0
d. Verify AS 9 loopback0 reachable by AS 1009 loopback0

R5

router bgp 1009
neigh 9.9.57.7 remote-as 9
address-family ipv4
neigh 9.9.57.7 activate
neigh 9.9.0.2 next-hop-self

R7

router bgp 9
neigh 9.9.57.5 remote-as 1009
address-family ipv4
neigh 9.9.57.5 activate
neigh 9.9.0.8 next-hop-self

R6

router bgp 1009
neigh 9.9.68.8 remote-as 9
address-family ipv4
neigh 9.9.68.8 activate
neigh 9.9.0.2 next-hop-self

R8

router bgp 9
neigh 9.9.68.6 remote-as 1009
address-family ipv4
neigh 9.9.68.6 activate
neigh 9.9.0.7 next-hop-self
neigh 9.9.0.9 next-hop-self

8.MP-BGP VPNv4 AS 1009

  a. Configure MP-BGP vpnv4 AS 1009 to support Layer 3 VPN (VRF)
b. R2 is RR AS 1009
c. Verify MP-BGP Vpnv4 running on AS 1009

R2

router bgp 1009
address-family vpnv4
neigh 9.9.0.1 activate
neigh 9.9.0.1 route-reflector-client
neigh 9.9.0.3 activate
neigh 9.9.0.3 route-reflector-client
neigh 9.9.0.4 activate
neigh 9.9.0.4 route-reflector-client
neigh 9.9.0.5 activate
neigh 9.9.0.5 route-reflector-client
neigh 9.9.0.6 activate
neigh 9.9.0.6 route-reflector-client

R1 sampai R6 (kecuali R2)

router bgp 1009
address-family vpnv4
neigh 9.9.0.2 activate

9.MP-BGP VPNv4 AS 9

  a. Configure MP-BGP vpnv4 AS 9 to support Layer 3 VPN (VRF)
b. R8 is RR AS 9
c. Verify MP-BGP Vpnv4 running on AS 9

R8

router bgp 9
address-family vpnv4
neigh 9.9.0.7 activate
neigh 9.9.0.7 route-reflector-client
neigh 9.9.0.9 activate
neigh 9.9.0.9 route-reflector-client

R7&R9

router bgp 9
address-family vpnv4
neigh 9.9.0.8 activate

10.Layer 3 VPN AS 1009

  a. Configure VRF BNI
     RD 1009:123
     RT export 1009:123
     RT import 1009:123
     interface loopback1 on PE associate with VRF
     make sure interface BNI associate with vrf
     make sure VRF BNI advertised to MP-BGP
######R2-R12######
R2

vrf definition BNI
rd 1009:123
address-family ipv4
route-target both 1009:123

interface lo1
vrf forwarding BNI
ip add 172.9.0.2 255.255.255.255

interface e0/2
vrf forwarding BNI
ip add 172.9.122.2 255.255.255.0

router bgp 1009
address-family ipv4 vrf BNI
neigh 172.9.122.12 remote-as 12
net 172.9.0.2 mask 255.255.255.255

R12

router bgp 12
neigh 172.9.122.2 remote-as 1009
net 172.9.0.12 mask 255.255.255.255

#################

######R3-R14######
R3

vrf definition BNI
rd 1009:123
address-family ipv4
route-target both 1009:123

interface lo1
vrf forwarding BNI
ip addr 172.9.0.3 255.255.255.255

int e0/2
vrf forwarding BNI
ip addr 172.9.143.3 255.255.255.0

router rip
address-family ipv4 vrf BNI
version 2
no auto-summ
network 172.9.143.0
network 172.9.0.3
redistribute bgp 1009 metric 1

router bgp 1009
address-family ipv4 vrf BNI
redistribute rip

R14

router rip
version 2
no auto-summ
network 172.9.143.0
network 172.9.0.14

#################

  b. Configure VRF BCA
     RD 1009:456
     RT export 1009:456
     RT import 1009:456
     interface loopback1 on PE associate with VRF
     make sure interface BCA associate with vrf
     make sure VRF BCA advertised to MP-BGP

######R1-R11######
R1

vrf definition BCA
rd 1009:456
address-family ipv4
route-target both 1009:456

interface lo1
vrf forwarding BCA
ip add 172.9.0.1 255.255.255.255

interface e0/2
vrf forwarding BCA
ip add 172.9.111.1 255.255.255.0

ip route vrf BCA 172.9.0.11 255.255.255.255 172.9.111.11

router bgp 1009
address-family ipv4 vrf BCA
redistribute static

R11

ip route 0.0.0.0 0.0.0.0 172.9.111.1

#################

######R4-R13######
R4

vrf definition BCA
rd 1009:456
address-family ipv4
route-target both 1009:456

interface lo1
vrf forwarding BCA
ip add 172.9.0.4 255.255.255.255

interface e0/2
vrf forwarding BCA
ip add 172.9.134.4 255.255.255.0

router eigrp 134
address-family ipv4 vrf BCA autonomous-system 134
redistribute bgp 1009 metric 1 1 1 1 1
network 172.9.134.0
network 172.9.0.4

router bgp 1009
address-family ipv4 vrf BCA
redistribute eigrp 134

R13

router eigrp 134
network 172.9.134.0
network 172.9.0.13

#################

11.Layer 3 VPN AS 9

  a. Configure VRF BCA
     RD 1009:789
     RT export 1009:789
     interface loopback1 on PE associate with VRF
     interface loopback1 on PE associate with VRF
     make sure interface BCA associate with vrf
     make sure VRF BCA advertised to MP-BGP

######R8-R16######
R8

vrf definition BCA
rd 1009:789
address-family ipv4
route-target both 1009:789

interface lo1
vrf forwarding BCA
ip add 172.9.0.8 255.255.255.255

interface e0/2
vrf forwarding BCA
ip add 172.9.168.8 255.255.255.0

router ospf 10 vrf BCA
network 172.9.168.0 0.0.0.255 area 0
network 172.9.0.8 0.0.0.0 area 0
redistribute bgp 9 subnets

router bgp 9
address-family ipv4 vrf BCA
network 172.9.0.8 mask 255.255.255.255
redistribute ospf 10

R16

router ospf 10
network 172.9.168.0 0.0.0.255 area 0
network 172.9.0.16 0.0.0.0 area 0

#################

######R9-R15######
R9

vrf definition BCA
rd 1009:789
address-family ipv4
route-target both 1009:789

interface lo1
vrf forwarding BCA
ip add 172.9.0.9 255.255.255.255

interface e0/2
vrf forwarding BCA
ip add 172.9.159.9 255.255.255.0

router bgp 9
address-family ipv4 vrf BCA
neigh 172.9.159.15 remote-as 15
neigh 172.9.159.15 activate
net 172.9.0.9 mask 255.255.255.255

R15

router bgp 15
neigh 172.9.159.9 remote-as 9
net 172.9.0.15 mask 255.255.255.255

#################

12. INTER-AS VPN Option B

  a. Activate Inter-AS VPN Option B
b. Configure eBGP VPNv4 between AS 1009 and AS 9,
c. Make sure BGP vpnv4 receive between AS 1009 and AS 9
d. Configure eBGP VPNv4 next-hop-self into iBGP vpnv4
e. Make sure VRF BCA AS 1009 able to reach VRF BCA AS 9

Inter-AS
option B

Step-1 : Activate MP-BGP VPNV4 between ASBR (R5-R7)
R5

router bgp 1009
address-family vpnv4
neigh 9.9.57.7 activate

R7

router bgp 9
address-family vpnv4
neigh 9.9.57.5 activate

Step-2 : ASBR set next-hop-self to IBGP Vpnv4

R5

router bgp 1009
address-family vpnv4
neigh 9.9.0.2 activate
neigh 9.9.0.2 next-hop-self

R2

router bgp 1009
address-family vpnv4
neigh 9.9.0.5 activate

R7

router bgp 9
address-family vpnv4
9.9.0.8 activate
9.9.0.8 next-hop-self

R8

router bgp 9
address-family vpnv4
neigh 9.9.0.7 activate

Step-3 : Set no bgp default route-target filter on ASBR

R5

router bgp 1009
no bgp default route-target filter

R7

router bgp 9
no bgp default route-target filter

Step-4 : Import/Export RT Value

R1

vrf definition BCA
address-family ipv4
route-target import 1009:789

R4

vrf definition BCA
address-family ipv4
route-target import 1009:789

R8

vrf definition BCA
address-family ipv4
route-target import 1009:456

R9

vrf definition BCA
address-family ipv4
route-target import 1009:456

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout /  Ubah )

Foto Google

You are commenting using your Google account. Logout /  Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout /  Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout /  Ubah )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.