iBGP Peering IOS-XR

Sebelum masuk ke konfigurasi iBGP (disini peering menggunakan loopback), masing-masing loopback harus sudah bisa diping satu sama lain. Maka dari itu kita perlu mengkonfigurasikan IGP terserah apa saja sesuai topologi atau bisa baca tulisan sebelumnya menggunakan OSPF.

xr2
Konfigurasi IDN-R1

RP/0/0/CPU0:IDN-R1(config)#router bgp 100
RP/0/0/CPU0:IDN-R1(config-bgp)#neigh 2.2.2.2
RP/0/0/CPU0:IDN-R1(config-bgp-nbr)#remote-as 100
RP/0/0/CPU0:IDN-R1(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IDN-R1(config-bgp-nbr)#neigh 3.3.3.3
RP/0/0/CPU0:IDN-R1(config-bgp-nbr)#remote-as 100
RP/0/0/CPU0:IDN-R1(config-bgp-nbr)#update-source lo0

Konfigurasi IDN-R2

RP/0/0/CPU0:IDN-R2(config)#router bgp 100
RP/0/0/CPU0:IDN-R2(config-bgp)#neigh 1.1.1.1
RP/0/0/CPU0:IDN-R2(config-bgp-nbr)#remote-as 100
RP/0/0/CPU0:IDN-R2(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IDN-R2(config-bgp-nbr)#neigh 3.3.3.3
RP/0/0/CPU0:IDN-R2(config-bgp-nbr)#remote-as 100
RP/0/0/CPU0:IDN-R2(config-bgp-nbr)#update-source lo0

Konfigurasi IDN-R3

RP/0/0/CPU0:IDN-R3(config)#router bgp 100
RP/0/0/CPU0:IDN-R3(config-bgp)#neigh 1.1.1.1
RP/0/0/CPU0:IDN-R3(config-bgp-nbr)#remote-as 100
RP/0/0/CPU0:IDN-R3(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IDN-R3(config-bgp-nbr)#neigh 2.2.2.2
RP/0/0/CPU0:IDN-R3(config-bgp-nbr)#remote-as 100
RP/0/0/CPU0:IDN-R3(config-bgp-nbr)#update-source lo0

Konfigurasi BGP peernya dengan menambahkan update-source loopback0. bila tidak ditambahkan baris tersebut maka yang digunakan updatenya adalah ip interface physical sehingga bgp adjacency nya akan bermasalah.

Verifikasi

RP/0/0/CPU0:IDN-R1#sh bgp summ
Mon Feb  3 19:41:16.377 UTC
BGP router identifier 1.1.1.1, local AS number 100
BGP generic scan interval 60 secs
BGP table state: Active
Table ID: 0xe0000000   RD version: 0
BGP main routing table version 1
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.

Process       RcvTblVer   bRIB/RIB   LabelVer  ImportVer  SendTblVer  StandbyVer
Speaker               1          1          1          1           1           1

Neighbor        Spk    AS MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down  St/PfxRcd
2.2.2.2           0   100       5       7        1    0    0 00:02:32          0
3.3.3.3           0   100       5       9        1    0    0 00:02:16          0

RP/0/0/CPU0:IDN-R1#

Pastikan pada bagian State/PfxRcd nya bernilai 0. Kemudian kita akan membuat sebuah loopback interface baru yang nantinya akan kita advertise ke dalam BGP

RP/0/0/CPU0:IDN-R1(config)#int lo1
RP/0/0/CPU0:IDN-R1(config-if)#ip addr 11.11.11.11 255.255.255.255
RP/0/0/CPU0:IDN-R2(config)#int lo1
RP/0/0/CPU0:IDN-R2(config-if)#ip addr 22.22.22.22 255.255.255.255
RP/0/0/CPU0:IDN-R3(config)#int lo1
RP/0/0/CPU0:IDN-R3(config-if)#ip addr 33.33.33.33 255.255.255.255

Kemudian kita akan advertise ke BGP

RP/0/0/CPU0:IDN-R1(config)#router bgp 100
RP/0/0/CPU0:IDN-R1(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IDN-R1(config-bgp-af)#network 11.11.11.11 255.255.255.255
RP/0/0/CPU0:IDN-R2(config)#router bgp 100
RP/0/0/CPU0:IDN-R2(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IDN-R2(config-bgp-af)#network 22.22.22.22 255.255.255.255
RP/0/0/CPU0:IDN-R3(config)#router bgp 100
RP/0/0/CPU0:IDN-R3(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IDN-R3(config-bgp-af)#network 33.33.33.33 255.255.255.255

Verifikasi

Pastikan route tersebut sudah diadvertise sehingga nilai State/PfxRcd nya menjadi 1

RP/0/0/CPU0:IDN-R1#sh bgp summ
Mon Feb  3 19:57:24.830 UTC
BGP router identifier 1.1.1.1, local AS number 100
BGP generic scan interval 60 secs
BGP table state: Active
Table ID: 0xe0000000   RD version: 4
BGP main routing table version 4
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.

Process       RcvTblVer   bRIB/RIB   LabelVer  ImportVer  SendTblVer  StandbyVer
Speaker               4          4          4          4           4           4

Neighbor        Spk    AS MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down  St/PfxRcd
2.2.2.2           0   100      22      24        4    0    0 00:18:41          1
3.3.3.3           0   100      22      26        4    0    0 00:18:25          1

RP/0/0/CPU0:IDN-R1#

Cek route yang diadvertise ke BGP dan kemudian cek routing tabelnya

RP/0/0/CPU0:IDN-R1#sh ip route
Mon Feb  3 20:00:57.996 UTC

Codes: C - connected, S - static, R - RIP, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - ISIS, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, su - IS-IS summary null, * - candidate default
U - per-user static route, o - ODR, L - local, G  - DAGR
A - access/subscriber, a - Application route, (!) - FRR Backup path

Gateway of last resort is not set

L    1.1.1.1/32 is directly connected, 01:47:48, Loopback0
O    2.2.2.2/32 [110/2] via 12.12.12.2, 00:54:03, GigabitEthernet0/0/0/5
O IA 3.3.3.3/32 [110/3] via 12.12.12.2, 00:54:14, GigabitEthernet0/0/0/5
L    11.11.11.11/32 is directly connected, 00:11:57, Loopback1
C    12.12.12.0/24 is directly connected, 01:47:48, GigabitEthernet0/0/0/5
L    12.12.12.1/32 is directly connected, 01:47:48, GigabitEthernet0/0/0/5
B    22.22.22.22/32 [200/0] via 2.2.2.2, 00:06:52
O IA 23.23.23.0/24 [110/2] via 12.12.12.2, 00:56:49, GigabitEthernet0/0/0/5
B    33.33.33.33/32 [200/0] via 3.3.3.3, 00:05:52
RP/0/0/CPU0:IDN-R1#

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s